Main Nav

Adobe Connect Technical Requirements

To participate you will need:

  • Internet: A high speed wired connection.
  • Audio: Computer speakers.
  • Backup audio: A reliable telephone, or a conference phone when participating as a team. If you have audio difficulties, visit the Audio Troubleshooting page.
  • Adobe Connect: Run this connection test. If you have problems completing the test or installing required software, visit the Adobe Support website or call Adobe Technical Support at 800-945-9120.

Other operating system, browser, and software requirements are below.

Software and Browser Requirements

Windows

  • Windows 8.1, Windows 8, Windows 7
  • Internet Explorer 8 or later; Windows Edge browser; Mozilla Firefox; Google Chrome
    Internet Explorer has the fewest compatibility issues.
  • Adobe Flash Player 13.0+

 

Linux

  • Ubuntu 14.04; Red Hat Enterprise Linux 6;  OpenSuSE 13.1
    • Presenters using Linux: There is no add-in support; you can attend the meeting only.
  • Google Chrome
  • Adobe Flash Player 13.0+

 

Mac OS

  • Mac OS X 10.8, 10.9, 10.10
  • Mozilla Firefox; Apple Safari; Google Chrome
    • Google Chrome has the fewest compatibility issues.
    • Safari: Make sure you have the latest Adobe Connect Add-in.
    • Safari 6+: Adjust your security settings and run educause.acms.com in unsafe mode. Click here for additional information and detailed instructions.
  • Adobe Flash Player 13.0+

Mobile Devices

Android Devices

  • Android supported OS versions:  2.3.4 and higher
  • Adobe Connect Mobile App via Google Play
  • Supported devices: Motorola DROID RAZR MAXX, Motorola Atrix, Motorola Xoom, Samsung Galaxy Tab 2 10.1, Samsung Galaxy S3 & S4, Nexus 7 tablet

Apple Devices